PHP 8.0 and PHP 7 legacy packages are available

The php package has been updated to version 8.0. Please refer to the upstream migration guide. As some applications are not compatible with PHP 8 yet we provide a php7 package which can be installed alongside version 8. Packages that depend on PHP reflect this update and will require php7 if needed. You might need to update your configuration accordingly. PHP 7 binaries and configuration have the “7” suffix:

  • /usr/bin/php -> /usr/bin/php7
  • /etc/php -> /etc/php7
  • /usr/bin/php-fpm -> /usr/bin/php-fpm7
  • /usr/lib/systemd/system/php-fpm.service -> /usr/lib/systemd/system/php-fpm7.service
  • /run/php-fpm -> /run/php-fpm7

We also provide third party modules compiled for PHP 7:

Note that support for php7 will be limited and likely be dropped in about a year depending on how soon the majority of applications will be compatible with version 8.


Go to Source ArchLinux // Author: Pierre Schmitz